Drainage Ditches POJ - 1273 (网络流最小割)

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

 

思路:设一个超级源点和所有居民建一条INF的边,跑一边Dinic,满流的边可就是割边了,但是,不是所有割边都符合题目要求,可以参考样例二,所以我们从s开始遍历,不走割边,能走到的点标记为1,再从t开始遍历,不走割边,能走到的点标记为2

,然后,所有起点编号为1,终点编号为2的边就是答案了,这里不靠考虑自己建的反边

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>
typedef long long LL;
using namespace std;
int INF = 1e9;
const int maxn = 1e5 + 50;
struct Edeg
{
    int u, to, next, w, id;
} edge[maxn];

int k, head[maxn];

void add(int a, int b, int c, int id){
    edge[k].u = a;
    edge[k].id = id;
    edge[k].to = b;
    edge[k].next = head[a];
    edge[k].w = c;
    head[a] = k++;

    edge[k].u = b;
    edge[k].id = id;
    edge[k].to = a;
    edge[k].next = head[b];
    edge[k].w = 0;
    head[b] = k++;
}

int dis[maxn];
int cur[maxn];

int bfs(int s, int t){
    queue<int> que;
    for(int i = 0; i <= s; i++){
        dis[i] = 0;
    }
    dis[s] = 1;
    que.push(s);
    while(que.size()){
        int u = que.front();
        que.pop();
        for(int i = head[u]; i != -1; i = edge[i].next){
            int to = edge[i].to;
            int w = edge[i].w;
            if(!dis[to] && w){
                dis[to] = dis[u] + 1;
                if(to == t){
                    return 1;
                }
                que.push(to);
            }
            
        }
    }
    return 0;
}

int dfs(int u, int maxf, int t){
    if(u == t){
        return maxf;
    }
    int ret = 0;
    for(int i = cur[u]; i != -1; i = edge[i].next){
        cur[u] = i;
        int to = edge[i].to;
        int w = edge[i].w;
        if(dis[to] == dis[u] + 1 && w){
            int mi = min(maxf - ret, w);
            w = dfs(to, mi, t);
            edge[i].w -= w;
            edge[i ^ 1].w += w;
            ret += w;
            if(ret == maxf){
                return ret;
            }
        }
    }

    return ret;
}

int Dinic(int s, int t){
    int ans = 0;
    while(bfs(s, t)){
        for(int i = 0; i <= s; i++){
            cur[i] = head[i];
        }
        ans += dfs(s, INF, t);
    }
    return ans;
}

vector<int> vec;
int vis[maxn];
int node_id[maxn];
void Find1(int u){
    vis[u] = 1;
    node_id[u] = 1;
    for(int i = head[u]; i != -1; i = edge[i].next){
        int to = edge[i].to;
        int w = edge[i].w;
        if(vis[to]){
            continue;
        }
        if(w){
            Find1(to);
        }
    }
}

void Find2(int u){
    vis[u] = 1;
    node_id[u] = 2;
    for(int i = head[u]; i != -1; i = edge[i].next){
        int to = edge[i].to;
        int w = edge[i ^ 1].w;
        if(vis[to]){
            continue;
        }
        if(w){
            Find2(to);
        }
    }
}

int main()
{
    int n, m, tt;
    while(1){
        scanf("%d%d%d", &n, &m, &tt);
        if(n == 0){
            break;
        }
        vec.clear();
        for(int i = 0; i <= n + m + 1; i++){
            node_id[i] = 0;
            head[i] = -1;
            vis[i] = 0;
        }
        k = 0;
        
        int s = n + m + 1, t = 0;
        for(int i = 1; i <= tt; i++){
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            add(a, b, c, i);
        }

        for(int i = 1; i <= n; i++){
            add(s, i, INF, -1);
        }

        Dinic(s, t);
        Find1(s);
        Find2(t);
        int flag = 0;
        for(int i = 0; i < k; i += 2){
            int u = edge[i].u, to = edge[i].to;
            if(node_id[u] == 1 && node_id[to] == 2){
                if(flag){
                    printf(" ");
                }
                printf("%d", edge[i].id);
                flag = 1;
            }
        }
        printf("\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值