Drainage Ditches POJ - 1273 (网络流,最大流)

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50


最裸的网络流算法,从1 到 n,最大流是多少,

Dinic 这个分层算法,


#include <bits/stdc++.h>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAXN = 500;
struct node{
    int next,v,w;
}edge[MAXN];
int head[MAXN],cur[MAXN],dep[MAXN];
int sign,n,m,s,t;
void add_edge(int u,int v, int w){
    sign++;
    edge[sign].next = head[u];
    head[u] = sign;
    edge[sign].v = v;
    edge[sign].w = w;
}
void init(){
    memset(head,-1,sizeof(head));
    s = 1; t = n;
    int x,y,z;
    sign = -1;
    for (int i = 0; i < m; i++){
        scanf("%d%d%d",&x,&y,&z);
        add_edge(x,y,z);
        add_edge(y,x,0);
    }
}

bool bfs(){
    queue<int>Q;
    while(!Q.empty()) Q.pop();
    Q.push(s);
    memset(dep,0,sizeof(dep));
    dep[s] = 1;
    while(!Q.empty()){
        int u = Q.front();
        Q.pop();
        for (int i = head[u]; i != -1; i = edge[i].next){
            int v = edge[i].v;
            if (dep[v]==0 && edge[i].w > 0)
            {
                dep[v] = dep[u]+1;
                if (v == t) return 1; //这是个优化,如果提前搜到 汇点,就退出来。
                Q.push(v);
            }
        }
    }
    if (dep[t]) return 1;
    return 0;
}

int dfs(int u,int flow){
    if (u == t || flow == 0) return flow; //我自己觉的,这个flow 可以优化,所以才 加上 flow == 0;
    for (int &i = cur[u]; i != -1; i = edge[i].next){  //&i  这个是引用,同时变。避免走重复的边。
        int v = edge[i].v,w = edge[i].w;
        if (dep[v] > dep[u] && w > 0){ 
            int d = dfs(v,min(flow,w));
            if (d){
                edge[i].w -= d; //正向边 减去流量,
                edge[i^1].w += d; //反向边 加上流量。
                return d;
            }
        }
    }
    return 0;
}

int Dinic(){
    int Ans=0,d;
    while(bfs()){
        for (int i = 1; i <= n; i++)
            cur[i] = head[i];  // cur 代表当前弧优化。一开始要初始化。
        while( d = dfs(s,INF)) {  //每次dfs返回一个最小的流量,然后接着搜dfs 直到dfs的结果为0,然后在bfs重新建深度。
            Ans += d;
        }
    }
    return Ans;
}

int main() {
    while(scanf("%d%d",&m,&n) == 2) {
        init();
        printf("%d\n", Dinic());
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值