迷宫问题

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


算是BFS模板题,,感觉难点在输出路径,,用一个结构体二维数组保存每个路过的点及其是如何变换来的,再从终点向起点推回去。
输出时可以将数据压入栈中,也可放入数组中,在倒序输出。

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<string>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<stack>

using namespace std;
typedef struct {  int a,b; int step;}test;
test st={0,0,0},ed={4,4,0},ans;

int t[10][10],ch[4][2]={{0,1},{1,0},{0,-1},{-1,0}},vis[10][10]={0};
test ans1[6][6];

bool check(test t2)
{
    if(t[t2.a][t2.b]==0 && vis[t2.a][t2.b]==0 && t2.a>=0 && t2.a<=4&& t2.b>=0 && t2.b<=4){
        return 1;
    }
    else return 0;
}

void bfs(test t1)
{
    int num=0;
    test no,ne;
    queue<test>q;
    q.push(t1);
    vis[t1.a][t1.b]=1;
    while(!q.empty()){
        no=q.front();
        q.pop();
        if(no.a==ed.a && no.b==ed.b){
            ans.step=no.step;
            return;
        }
        for(int i=0;i<4;i++){
            ne.a=no.a+ch[i][0];
            ne.b=no.b+ch[i][1];
            ne.step=no.step+1;
            if(check(ne)){
                q.push(ne);
                ans1[ne.a][ne.b].a=ch[i][0];
                ans1[ne.a][ne.b].b=ch[i][1];
                vis[ne.a][ne.b]=1;
                //cout<<ne.a<<" "<<ne.b<<endl;
                //cout<<ch[i][0]<<" "<<ch[i][1]<<endl;
            }
        }
    }
}

int main()
{
    for(int i=0;i<5;i++){
        for(int j=0;j<5;j++){
            cin>>t[i][j];
        }
    }
    bfs(st);
    int ans2[30][2];
    int x=4,y=4,m=4,n=4;   //输出
    for(int i=0;i<=ans.step;i++){
        ans2[i][0]=x;
        ans2[i][1]=y;
        m-=ans1[x][y].a;
        n-=ans1[x][y].b;
        x=m;
        y=n;
    }
    for(int i=ans.step;i>=0;i--){
        cout<<"("<<ans2[i][0]<<", "<<ans2[i][1]<<")"<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值