PAT(A)1144 The Missing Number (20point(s))

在这里插入图片描述

Sample Input

10
5 -25 9 6 1 3 4 2 5 17

Sample Output

7

思路:
排序后找到最靠近的缺少的数,注意第一个大于1就是1.
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <map>
#include <cmath>

using namespace std;

#define endl '\n'

typedef long long ll;

vector<ll>v;
map<ll, ll>mp;

int main()
{
    int n;
    cin >> n;

    int maxn = 0;

    for (int i = 0; i < n; ++i)
    {
        ll x;
        cin >> x;
        if (x < 0) continue;
        mp[x] = 1;
        v.push_back(x);
    }
    sort(v.begin(), v.end());

    
    if (mp[1] != 1)
    {
        cout << "1" << endl;
        return 0;
    }

    for (int i = 0; i < v.size(); ++i)
    {
        if (mp[v[i] + 1] != 1)
        {
            cout << v[i] + 1 << endl;
            break;
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值