PAT(A)1063 Set Similarity (25point(s))

在这里插入图片描述

Sample Input

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output

50.0%
33.3%

思路:
判重,然后算重复率。
我本来想用map判重,最后一个点会超时,set在插入的时候就可以直接去重。
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <vector>
#include <map>
#include <cmath>
#include <set>

using namespace std;

#define endl '\n'

typedef long long ll;


int main()
{
    int n;

    scanf("%d", &n);


    vector<set<ll> >v(n);

    for (int i = 0; i < n; ++i)
    {
        int m;
        scanf("%d", &m);

        set<ll>s;

        while (m--)
        {
            int x;
            scanf("%d", &x);

            s.insert(x);
        }

        v[i] = s;
    }

    int k;

    scanf("%d", &k);

    while (k--)
    {
        int x, y;
        scanf("%d %d", &x, &y);

        int nc = 0, nt = v[x - 1].size();

        for (auto it = v[y - 1].begin(); it != v[y - 1].end(); it++)
        {
            if (v[x - 1].find(*it) != v[x - 1].end())
                nc++;
            else
                nt++;
        }
        printf("%.1lf%%\n", nc * 100.0 / nt);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值