(kuangbin带你飞--最短路径)Heavy Transportation

原题目:

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

从点1到点n,很多条路径,每条路径都有一个最小的权值,求这些最小的权值里的最大值。

就是不断维护d数组

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
const int M=1005;
int t,n,m,cas=0;
int mmp[M][M],vis[M],d[M];

//vis数组用来判断是否查询过
//mmp数组储存图
//d数组表示1到N的最大距离
void dijk()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        d[i]=mmp[1][i];
    d[1]=0;
    vis[0]=1;
    for(int i=1;i<=n;i++)
    {
        int u=-1,m=0;//m表示此时i到各个点的最大距离
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]>m)
            {
                m=d[j];
                u=j;
            }
        }
        vis[u]=1;
        for(int i=1;i<=n;i++)
        {
            if(mmp[u][i])
                d[i]=max(d[i],min(d[u],mmp[u][i]));
        }
    }
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(mmp,0,sizeof(mmp));
       int u,v,w;
       scanf("%d%d",&n,&m);
       for(int i=1;i<=m;i++)
       {
           scanf("%d%d%d",&u,&v,&w);
           mmp[u][v]=mmp[v][u]=w;
       }
       dijk();
       if(cas) puts("");
       printf("Scenario #%d:\n",++cas);
       printf("%d\n",d[n]);
    }
}

这道题目要求的是从1到N各个路径最小值的最大值,即d[y]=max(d[y],min(d[x],m[x][y])).

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值