kuangbin专题四-Heavy Transportation(最短路)

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4

题意:1到n个路口,每条路都有最大可承受重量,给出起点终点,找到最大的承重能力,算出从1-n可以运输的最大重量,给出u,v,w。
输出可以运输的最大允许重量
思路:这题是dij的变形
先找到从1到其他路口的路径中的最小组成边。(因为最大承重是这个路径中最小的那个边决定的,就有点像那个木桶原理)
然后与它本身的dis去比较大小,找到路径中最小组成边中的最大的。(更新它的dis值,因为尽量最大允许重量,就在这些最小边中找最大的)
即为dis[i]。
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
const int N=2000;
const int INF=0x3f3f3f3f;
int n,m;
int G[N][N];//存图
int dis[N];//存到每个点路径的最大承受值
bool vis[N];//判断这个点是已经找到过了
void dij ()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++){
        dis[i]=G[1][i];//初始化为1-i的距离
    }
    dis[1]=0;//到自己点为0
    vis[1]=1;//标记
    for(int i=1;i<=n;i++){
        int maxx=-1,k;
        for(int j=1;j<=n;j++){
            if(vis[j]==0&&dis[j]>maxx){//找目前没被标记过的点中dis承受值最大的点,这样就能使值越来越大
                maxx=dis[j];
                k=j;
            }
        }
        vis[k]=1;//标记
        for(int j=1;j<=n;j++){
            dis[j]=max(dis[j],min(dis[k],G[k][j]));//先判断通过这条路径中最小的边,然后来让最小的边与原来的值比较,更新(最小的边即为最大的承受量)
        }
    }
}
int main ()
{
    int t;
    scanf("%d",&t);
    int sum=0;
    while(t--){
        memset(G,0,sizeof(G));
        scanf("%d %d",&n,&m);
        for(int i=1;i<=m;i++){
            int u,v,w;
            scanf("%d %d %d",&u,&v,&w);
            G[u][v]=w;//读图
            G[v][u]=w;
        }
        dij();
        sum++;
        printf("Scenario #%d:\n",sum);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值