原题目:
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
中文概要:
给出一段序列,求问哪些到哪些字符位置可以刚好构成多次循环,并给出循环的次数。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1000005;
char str[maxn];
int Next[maxn];
void MakeNext(int m){
Next[0] = -1;
int i = 0,j = -1;
while(i < m){
if(j == -1 || str[i] == str[j])
Next[++i] = ++j;
else
j = Next[j];
}
}
int main(){
int len,length,time;
int cas = 0;
while(scanf("%d",&len) != EOF && len != 0){
scanf("%s",str);
MakeNext(len);
printf("Test case #%d\n",++cas);
for(int i = 2;i <= len;i ++){
length = i - Next[i];//循环节长度
if(i % length != 0 || length == i)
continue;
else
time = i / length;
printf("%d %d\n",i,time);
}
printf("\n");
}
return 0;
}
思路:
仔细想想也不难理解,主要是这句话
length = i - Next[i];
其实就是找循环节,理解就不难了
生成Next数组,根据数组求出循环节长度length = len - Next[len],再通过循环节长度判断是否符合输出条件