算法题 拓扑排序-07-Triangle LOVE

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
Case #1: Yes
Case #2: No

给定n个人,n*n的关系矩阵,a[i][j]为1表示i喜欢j,0表示不喜欢。没有自恋和情投意合的情况。求是否有三角恋。判断拓扑排序存不存在环,先找没人喜欢的出来。因为三角恋存在的话不可能存在一个没有人喜欢的人。然后就判断出队的人数是否跟总数相同,不同肯定存在三角恋

#include<iostream>
#include<vector>
#include<string>
#include<queue>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,i,count,j;
vector<int> map[2005];
int in[2005];
bool topospot() {
	int count = 0;
	queue<int> q;
	for (i = 0; i < n; i++) {
		if (in[i] == 0) {
			q.push(i);
		}
	}
	while (!q.empty()) {
		int u = q.front();
		q.pop();
		count++;
		in[u]--;
		for (i = 0; i < map[u].size(); i++) {
			int v = map[u][i];
			in[v]--;
			if (in[v] == 0) {
				q.push(v);
			}
		}
	}
	return count != n;
}
int main() {
	int k = 1;
	int T;
	scanf("%d", &T);
	while (T--) {
		for (int i = 0; i <= n; i++)
		{
			map[i].clear();
			in[i] = 0;
		}
		scanf("%d", &n);
		char s[2005];
		for (int i = 0; i < n; i++) {
			scanf("%s", s);
			for (int j = 0; j<n; j++) {
				if (s[j] == '1') {
					map[i].push_back(j);
					in[j]++;
				}
			}
		}
		
		bool z = topospot();
		if (z) {
			printf("Case #%d: Yes\n",k++);
		}
		else {
			printf("Case #%d: No\n",k++);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值