HDU 4324 Triangle LOVE 拓扑排序

题目描述:

Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.

Sample Input

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110 

Sample Output

Case #1: Yes
Case #2: No 

题目大意:

这道题是个悲伤的故事。
给定n个人,n*n的关系矩阵,a[i][j]为1表示i喜欢j,0表示不喜欢。没有自恋和情投意合的情况。求是否有三角恋。(不相信真爱了)

这道题其实就是拓扑排序求是否有环。我用的是遍历各个点的入度(喜欢他的人),如果每个点的入度都大于0,必然有环。将入读为0的点以及边删除,继续寻找,如果点全部删除了还没有,那就没有环了。。

代码如下:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const double eps = 1e-4;
const int MAXN=2020;

char mp[MAXN][MAXN];
int in[MAXN];
int T;
int n;

bool topsort()
{
    int i,j,k;
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=n; j++)
        {
            if (in[j]==0) break;//入度为0的点
        }
        if (j==n+1) return true;//寻找完毕
        else
        {
            in[j]--;//删点
            for(k=1; k<=n; k++)
            {
                if (mp[j][k]=='1' && in[k]!=0) in[k]--;
                //删边
            }
        }
    }
    return false;
}
int main()
{
    scanf("%d",&T);
    for(int t=1; t<=T; t++)
    {
        memset(in,0,sizeof(in));
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%s",mp[i]+1);
            for(int j=1; j<=n; j++)
            {
                if (mp[i][j]=='1')  in[j]++;
            }
        }
        if (topsort()==true) printf("Case #%d: Yes\n",t);
        else printf("Case #%d: No\n",t);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值