代码问题

模拟算法Tick and Tick(存在精度和时间限制问题)
/*
Problem Description
The three hands of the clock are rotating
every second and meeting each other many times everyday.
Finally, they get bored of this and each of them would
like to stay away from the other two. A hand is happy
if it is at least D degrees from any of the rest. You
are to calculate how much time in a day that all the hands
are happy.

Input
The input contains many test cases. Each of them has a single line
with a real number D between 0 and 120, inclusively. The input is
terminated with a D of -1.

Output
For each D, print in a single line the percentage of time in a day
that all of the hands are happy, accurate up to 3 decimal places.

Sample Input
0
120
90
-1

Sample Output
100.000
0.000
6.251
/
#include <stdio.h>
#include <math.h>
int main()
{
int flag,count,i;
double A,B,C,D,second,minute,hour,result,second1,minute1,hour1;
scanf("%lf",&D);
while(D!=-1)
{
count=0;
second=0;
minute=0;
hour=0;
for(i=1;i<=43200;i++)
{
flag=0;
second+=6
i;
minute+=0.1i;
hour+=6/360.0
i;
while(second>360)
{
second=second-360;
}
while(minute>360)
{
minute=minute-360;
}
while(hour>360)
{
hour=hour-360;
}
A=fabs(hour-minute);
B=fabs(minute-second);
C=fabs(hour-second);
if(A>=D&&B>=D&&C>=D)
{
flag=1;
}
if(flag)
{
if(360-A>=D&&360-B>=D&&360-C>=D)
{
count++;
}
}
}
result=count/43200.0*100;
printf("%.3lf\n",result);
scanf("%lf",&D);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值