PAT (Advanced Level) Practice 1052 Linked List Sorting (25 分)

19 篇文章 0 订阅
17 篇文章 0 订阅

题目

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 1 0 5 10^5 105​​ ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next
where Address is the address of the node in memory, Key is an integer in [ − 1 0 5 -10^5 105, 1 0 5 10^5 105​ ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

吐槽点
存在没有符合链表的情况,但也需要输出。

代码

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct Node{
	int add;
	int data;
	int next;
	int flag = 0;
};
bool cmp(Node n1,Node n2)
{
	if(n1.flag == n2.flag)
		return n1.data < n2.data;
	else
		return n1.flag > n2.flag;
}
int main()
{
	int n,sadd;
	cin >> n >> sadd;
	Node node[100000];
	int add,data,next;
	vector<Node> v;
	for(int i = 0;i < n;i++)
	{
		cin >> add >> data >> next;
		node[add].add = add;
		node[add].data = data;
		node[add].next = next;
	}
	int cnt = 0;
	while(sadd != -1)
	{
		node[sadd].flag = 1;
		sadd = node[sadd].next;
		cnt++;
	}
	if(cnt == 0)
		cout << "0 -1";
	else
	{
		sort(node,node+100000,cmp);
		printf("%d %05d\n",cnt,node[0].add);
		for(int i = 0;i < cnt-1;i++)
		{
			printf("%05d %d %05d\n",node[i].add,node[i].data,node[i+1].add);
		}
		printf("%05d %d -1\n",node[cnt-1].add,node[cnt-1].data);
	}
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

weixin_43820008

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值