D - Bomb
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15
Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=30;
ll dp[N][2],a[N],t[N];
ll n;
ll dfs(int pos, int sta,bool limit)
{
if(pos==0) return 0;
if(!limit&&dp[pos][sta]>=0) return dp[pos][sta];
int up;
if(limit) up=a[pos];
else up=9;
ll sum=0;
for(int i=0; i<=up; i++)
{
if(sta&&i==9)
sum+=limit?n%t[pos-1]+1:t[pos-1];
else
sum+=dfs(pos-1,i==4,i==a[pos]&&limit);
}
if(!limit) dp[pos][sta]=sum;
return sum;
}
ll solve(ll x)
{
int len=0;
memset(dp,-1,sizeof(dp));
while(x)
{
a[++len]=x%10;
x=x/10;
}
return dfs(len,0,1);
}
int main()
{
t[0]=1;
for(int i=1;i<=20;i++)
{
t[i]=t[i-1]*10;
}
int T;
cin>>T;
while(T--)
{
cin>>n;
cout<<solve(n)<<endl;
}
return 0;
}