1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​​ -city2
​​and city1-city​3​​.Then if city​1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意

城市之间由公路连接,若城市被侵略,则与它相连的公路全部关闭,需要修补公路使得剩余的城市连通
输入:
 N,M,K N–城市总数<1000;M–公路数目,K–需要检查的城市的数目
 接下来M行,每行两个整数 由公路相连的两个城市的编号,城市从1-N编号
 K个数, 我们要查询的城市的编号
输出:
 如果该城市被侵略的话,需要修补的公路条数

解题思路

题意是求去掉该结点及与其相连的边后,剩余顶点组成的连通块的个数,所需修补的公路数为连通块个数减一,使用DFS求得连通块个数

#include<iostream>
#include<cstring>
using namespace std;
const int MAXV = 1010;
int edge[MAXV][MAXV];
int vis[MAXV];
int n, m, k;
void DFS(int s){
	vis[s] = 1;
	for(int i = 1; i <= n; i++)
		if(!vis[i] && edge[s][i])
			DFS(i);
}
int main()
{
	int u, v;
	cin>>n>>m>>k;
	for(int i = 0; i < m; i++){
		cin>>u>>v;
		edge[u][v] = edge[v][u] = 1;
	}
	for(int i = 0; i < k; i++){
		int count = 0;
		cin>>u;
		memset(vis, 0, sizeof(vis));
		vis[u] = 1; 
		for(int j = 1; j <= n; j++){
			if(!vis[j]){
				count++;
				DFS(j);
			}
		}
		printf("%d\n", count-1);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值