问题 B: Day of Week

《算法笔记》3.4小节-日期处理

问题 B: Day of Week
题目描述
We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.
输入
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.
输出
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.
样例输入
21 December 2012
5 January 2013
样例输出
Friday
Saturday

#include<cstdio>
#include<cstring>
int leap(int n){
if((n%4==0&&n%100!=0)||n%400==0)
    return 1;
else
     return 0; 
}
int change(char *month)
{ 
    char a[15][20] = {"0","January","February","March","April","May","June","July","August","September","October","November","December"};
    for(int k=1;k<=12;k++)
    {
    	if(strcmp(month,a[k])==0) return k;	
	}
}
int main()
{
	char mon[20];
	char b[10][20] = {"Monday","Tuesday","Wednesday","Thursday","Friday","Saturday","Sunday"};
	int num[13][2]={{0,0}, {31,31}, {28,29}, {31,31}, {30,30}, {31,31}, {30,30}, {31,31}, {31,31}, {30,30}, {31,31}, {30,30}, {31,31}};
	int year,day,sum,mm;
	while(scanf("%d%s%d",&day,mon,&year)!=EOF)
	{
		sum=0;
		for(int i=1;i<year;i++)
		 {
		 	if(leap(i)==1)
		 	sum+=366;
		 	else 
		 	sum+=365;
		 }
	     mm=change(mon);
		 for(int j=1;j<mm;j++)
		 {
		 	sum+=num[j][leap(year)];
		 }
		 sum+=day;
		// printf("%d\n",sum);
		// printf("%d\n",sum%7);
		 if (sum%7 == 0)
        printf("Sunday\n");
        else
        printf("%s\n", b[sum%7 -1]);
	  }
	  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值