问题 G: 比较字符串

《算法笔记》3.6小节-字符串处理

问题 G: 比较字符串
题目描述
输入两个字符串,比较两字符串的长度大小关系。
输入
输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。
输出
输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。
样例输入
2
abc xy
bbb ccc
样例输出
abc is longer than xy
bbb is equal long to ccc

#include<cstdio>
#include<cstring>
int main()
{
	int m;
	char A[51],B[51];
	scanf("%d",&m);
	for(int i=0;i<m;i++)
	{
		scanf("%s%s",A,B);
		if(strlen(A)==strlen(B))
		{
			printf("%s is equal long to %s",A,B);
		}
		if(strlen(A)>strlen(B))
		{
			printf("%s is longer than %s",A,B);
		}
		if(strlen(A)<strlen(B))
		{
			printf("%s is shorter than %s",A,B);
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值