Just another Robbery(LightOJ-1079) 概率DP

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Note

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

 

题意:有n个银行要去抢劫,每个银行有两个值,一个是银行的钱,第二个是抢这个银行被抓住的概率,现在给出抢银行时的最大忍受的被抓住的概率,求最多能抢多少钱。
思路:银行1个1个的抢过去,抢到的钱随着抢劫银行的数量增加或者不变(不变的情况就是不抢劫该银行),被捕的概率随着银行数量的增加而增大或者不变(不变的情况就是不抢劫该银行),所以这个题有三个量在改变,一个是银行的数量,一个是抢到的钱,还有一个是被捕的概率。
所以用二维dp来表示三个变量,设dp[i][j]表示抢劫了前i个银行,抢了j的钱被捕的概率, dp[i][j] = min(dp[i-1][j],dp[i-1][j-a[i]] + (dp[i-1][j-a[i]) * b[i])
其中a[i]表示第i个银行的有多少钱,b[i]表示抢劫第i个银行被捕的概率, 用 j变量控制 i状态下抢劫获得的钱数,当j > a[i]的时候存在两种可能:抢劫该银行,不抢劫该银行。这时选择最小值。

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#include <iomanip>
typedef long long ll;
const int maxx=10010;
const int inf=0x3f3f3f3f;
using namespace std;
double dp[110][maxx];
int a[110];
double b[110];
int main()
{
    double k;
    int T,t,n;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        cin>>k>>n;
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i]>>b[i];
            sum+=a[i];
        }
        for(int j=1;j<=sum;j++)
            dp[0][j]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=sum;j++)
            {
                if(j>=a[i])
                    dp[i][j]=min(dp[i-1][j],dp[i-1][j-a[i]]+(double)(1-dp[i-1][j-a[i]])*b[i]);
                else
                    dp[i][j]=dp[i-1][j];
            }
        }
        int ans=0;
        for(int j=1;j<=sum;j++)
        {
            if(dp[n][j]<k)
                ans=j;
        }
        cout<<"Case"<<" "<<t<<":"<<" "<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值