Repository(HDU-2846)(字典树)

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

Input

There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

Output

For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

Sample Input

20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s

Sample Output

0
20
11
11
2

 

题意:给你p个商品名称,然后输入q个字符串查询,对每个查询输出含有查询串为子串的商品个数。
思路:这道题的话,很明显需要用字典树来做。字典树能很快的求出字典中以某个串为前缀的串的个数 ,但现在要查的是以某个串为子串的串的个数,然后我们可以发现一个串的任何子串肯定是这个串某个后缀的前缀。那么我们在向字典树中插入时可以把这个串的所有后缀都插入,插入时要注意来自同一个串的后缀的相同前缀只能统计一次,这用一个num数组标记就行了。这样最后字典树中以查询串为前缀的串的个数就是原始串中以查询串为子串的串的的个数了。

AC代码:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=1000010;
const int maxn=26;
const int inf=0x3f3f3f3f;
using namespace std;
int Trie[maxx][maxn];
int color[maxx];
int num[maxx];
char s[maxn];
int k;
void init()
{
    memset(Trie,0,sizeof(Trie));
    memset(color,0,sizeof(color));
    k=0;
}
void insert(char *w,int q)
{
    int p=0;
    int len=strlen(w);
    for(int i=0; i<len; i++)
    {
        int c=w[i]-'a';
        if(!Trie[p][c])
            Trie[p][c]=++k;
        p=Trie[p][c];
        if(num[p]!=q)
            color[p]++;
        num[p]=q;
    }
}
int search(char *w)
{
    int p=0;
    int len=strlen(w);
    for(int i=0; i<len; i++)
    {
        int c=w[i]-'a';
        if(!Trie[p][c])
            return 0;
        p=Trie[p][c];
    }
    return color[p];
}
int main()
{
    int p,q;
    scanf("%d",&p);
    for(int i=1; i<=p; i++)
    {
        scanf("%s",s);
        for(int j=0; j<strlen(s); j++)
            insert(s+j,i);
    }
    scanf("%d",&q);
    while(q--)
    {
        scanf("%s",s);
        printf("%d\n",search(s));
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值