HDU 2846 Repository

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6416    Accepted Submission(s): 2088


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
 
 
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
 
 
0 20 11 11 2
 
这题内存超级严,每次都内存超限,65536K的内存限制
最后只优化到了65700K,企图碰运气多交几次搞过去,
结果wa了四五十次。就先这样吧。
思路:每个长度为L的字符串建L个树,但是这里要注意查重,
num数组用来防止重复,同一个字符串的子串如果走了相同的
路径则跳过,否则sum[i]++.
代码:

#include<cstdio>
#include<string.h>
using namespace std;
int tire[700003][26];
int pos=1;
int sum[700003];
int num[700003];
char t[21],s[21];
void insert(const char *s,int k)
{
    int c=0;
    while(*s!='\0')
    {
        int t=*s-'a';
        if(tire[c][t]==0)
            tire[c][t]=pos++;
        c=tire[c][t];
        if(num[c]!=k)
        {
            num[c]=k;
            sum[c]++;
        }
        s++;
    }
}
int search(const char *s)
{
    int c=0;
    while(*s!='\0')
    {
        int t=*s-'a';
        if(tire[c][t]==0)
            return 0;
        c=tire[c][t];
        s++;
    }
    return sum[c];
}
int main()
{
    int i,j,n,m;
    //memset(sum,0,sizeof(sum));
    //memset(tire,0,sizeof(tire));
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%s",&t);
        int L=strlen(t);
        for(j=0;j<L;j++)
        {
            strncpy(s,t+j,L-j);//t数组从第j个元素开始的L-j个元素
                                //赋给s。
            insert(s,i);
        }
    }
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%s",&t);
        printf("%d\n",search(t));
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值