Big Event in HDU (HDU-1171)(母函数)

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

题意:大概就是给你一堆东西,第一行数据表示东西的种类,而后面再输入两个数,第一个代表物品的价值(v) ,第二个代表物品的个数(n),然后需要你开始按照价值分配给 a 和 b 两个组,同时要求 a ,b 两组后面的价值要尽可能的接近,并且保证 a 组的所获得价值不小于 b 组所获得的价值。

思路:这道题的话,难点在于怎么用母函数来做,在读题之后,我们发现它让你将总和/2,然后我们算出总和,套用一下模板即可。

AC代码:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=250010;
const int inf=0x3f3f3f3f;
using namespace std;
int sup[maxx],temp[maxx];
int v[maxx],m[maxx];
int main()
{
    int n;
    while(~scanf("%d",&n) && n>=0)
    {
        for(int i=0; i<n; i++)
            scanf("%d%d",&v[i],&m[i]);
        int last=0,last2;
        memset(sup,0,sizeof(sup));
        sup[0]=1;
        for(int i=0; i<n; i++)
        {
            last2=last+v[i]*m[i];
            memset(temp,0,sizeof(int)*(last2+1));
            for(int j=0; j<=m[i] && j*v[i]<=last2; j++)
            {
                for(int k=0; k<=last && k+j*v[i]<=last2; k++)
                {
                    temp[k+j*v[i]]+=sup[k];
                }
            }
            memcpy(sup,temp,sizeof(int)*(last2+1));
            last=last2;
        }
        for(int i=last/2; i>=0; i--)
        {
            if(sup[i]!=0)
            {
                printf("%d %d\n",last-i,i);
                break;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值