广搜(BFS)和上一篇DFS用的一道例题:迷宫问题
问题描述:
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
输入描述:
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
输出描述:
左上角到右下角的最短路径,格式如样例所示。
样例输入:
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
样例输出:
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
BFS也就是广度优先搜索,意思就是把全部的都搜素一遍,我也是看了某大佬的博客,感觉他写的不错。大佬的文章
此处放上AC代码:
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
int map[7][7];
int vis[7][7];
int mov[4][2]={1,0,0,-1,-1,0,0,1};
int sx=0,sy=0;
struct node
{
int x,y;
int step;
}foot[30];
int valid(int x,int y)
{
if(x>=0 && x<5 && y>=0 && y<5)
return 1;
else
return 0;
}
void print(int a)
{
if(foot[a].step!=-1)
{
print(foot[a].step);
printf("(%d, %d)\n",foot[a].x,foot[a].y);
}
}
void bfs()
{
int front=0,rear=1;
foot[front].x=sx;
foot[front].y=sy;
foot[front].step=-1;
while(front<rear)
{
for(int i=0;i<4;i++)
{
int a=foot[front].x+mov[i][0];
int b=foot[front].y+mov[i][1];
if(!vis[a][b] && !map[a][b] && valid(a,b))
{
vis[a][b]=1;
foot[rear].x=a;
foot[rear].y=b;
foot[rear].step=front;
rear++;
}
if(a==4 && b==4)
print(front);
}
front++;
}
}
int main()
{
for(int i=0;i<5;i++)
for(int j=0;j<5;j++)
{
scanf("%d",&map[i][j]);
vis[i][j]=0;
}
printf("(0, 0)\n");
bfs();
printf("(4, 4)\n");
return 0;
}