Cow Contest (POJ-3660)

Cow Contest (POJ-3660)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题目翻译:

N(1≤N≤100)头奶牛,方便编号1。正在参加一个编程比赛。我们都知道,有些奶牛的代码比其他奶牛好。每头牛都有一个固定的技能等级,这在竞争对手中是独一无二的。

比赛分几轮进行,每轮由两头奶牛进行。如果奶牛A的技能水平高于奶牛B(1≤A≤N;1≤B≤N;A≠B),那么奶牛A总是会打败奶牛B。

农民约翰正试着按技术水平给牛排序。给出一列M(1≤M≤4500)双牛轮的结果,根据结果确定可精确确定其等级的奶牛数。保证各回合的结果不会相互矛盾。

输入

*第1行:两个空格分隔的整数:N和M

*线2 . .M+1:每一行包含两个空格分隔的整数,它们描述了一轮比赛的竞争者和结果(第一个整数A是获胜者):A和B

输出

*第1行:单个整数,表示可以确定的奶牛数量

题目大意:有N头牛,评以N个等级,各不相同,先给出部分牛的等级的高低关系,问最多能确定多少头牛的等级。
解题思路:一头牛的等级,当且仅当它与其它N-1头牛的关系确定时确定,于是我们可以将牛的等级关系看做一张图,然后进行适当的松弛操作,得到任意两点的关系,再对没一头牛进行检查即可。

AC代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#include <string.h>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <stdlib.h>
#define inf 0x3f3f3f3f
#define PI 3.1415926
#define MAX 550
using namespace std;
int dp[MAX][MAX];
int n,m;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,inf,sizeof(dp));
        int a,b;
        int i,j,k;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            dp[a][b]=1;
            dp[b][a]=-1;
        }
        for(k=1; k<=n; k++)
            for(i=1; i<=n; i++)
                for(j=1; j<=n; j++)
                {
                    if(dp[i][k]==dp[k][j] && dp[i][k]!=inf)//如果说i->k的关系确定,k->j的关系确定的话,i->j的关系就确定了

                        dp[i][j]=dp[i][k];
                }
        int ans=0;
        for(i=1; i<=n; i++)
        {
            int sum=0;
            for(j=1; j<=n; j++)
            {
                if(dp[i][j]!=inf)
                    sum++;
            }
            if(sum==n-1)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值