POJ 1850 Code 【组合数学】

传送门:POJ 1850


Code
Time Limit: 1000MS Memory Limit: 30000K

Problem Description
Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, …, z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).
The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2

z - 26
ab - 27

az - 51
bc - 52

vwxyz - 83681

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input
The only line contains a word. There are some constraints:
• The word is maximum 10 letters length
• The English alphabet has 26 characters.

Output
The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input
bf

Sample Output
55


题意:
输出某个str字符串在字典中的位置,由于字典是从a=1开始的,因此str的位置值就是 在str前面所有字符串的个数 +1
规定输入的字符串必须是升序排列。不降序列是非法字符串。

题解:
首先第一步当然是判断是不是合法字符串
若符合第一步,则首先计算比str长度少的所有字符串个数

长度为n的字符串要满足升序排列, 只需要在26个字母种 选出n个字符就可以了 因为升序排列只有一种。所以就是就 C 26 n C_{26}^n C26n了。

那么我们接下来要求的就是长度相等,但是小于str的字符串个数了,详情见代码。

最后求出来的总数加一即可,因为没有算上str他本身。



AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
int c[30][30];
void fun()//求组合数
{
	int i,j;
	for(i=0;i<30;i++)
	{
		c[i][0]=1;
	}
	for(i=1;i<30;i++)
	{
		for(j=1;j<30;j++)
			c[i][j]=c[i-1][j-1]+c[i-1][j];
	}
}
int main()
{
	char s[20];
	fun();
	while(scanf("%s",s)!=EOF)
	{
		int len=strlen(s);
		ll sum=0;
		for(int i=0;i<len-1;i++)
		{
			if(s[i]>s[i+1])
			{
				printf("0\n");//一旦s不符合字典要求(如aab,ba等)就要结束程序
				return 0;
			}
		}
		for(int i=1;i<len;i++)//计算长度比s小的字符串个数
		{
			sum+=c[26][i];
		}
		for(int i=0;i<len;i++)
		{
			char ch;
			if(i==0)// ch=str[i-1]+1 根据升序规则,当前位置的ch至少要比str前一位置的字符大1
				ch='a';
			else
				ch=s[i-1]+1;
			while(ch<s[i])//当前位置的ch最多只能比s这个位置实际上的字符小1
			{
				sum+=c['z'-ch][len-i-1];
				ch++;
			}
		}
		printf("%lld\n",++sum);
	}
  return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值