多边形重心的计算

例题:

传送门:HDU 1115


方法一:

累加求和重心。

设平面上有n个点(xi,yi)(i=1、2、3……n),其多边形重心G(x,y)为:
在这里插入图片描述
这是求多边形最简单直观的方法。可以直接利用数据点的x, y坐标就能求图形重心。但是缺陷在于没有对离散数据点所围图形做任何处理和分析,精度不够



方法二:

这里有几个定理需要用到:

定理一:已知三角形△A1A2A3的顶点坐标Ai ( xi, yi ) ( i =1, 2, 3) 。它的重心坐标为:
xc = (x1+x2+x3) / 3 ; yc = (y1+y2+y3) / 3 ;

定理二:已知三角形△A1A2A3的顶点坐标Ai ( xi , yi ) ( i =1, 2, 3) 。该三角形的面积为:
  S = ( (x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1) ) / 2 ;
  △A1A2A3 边界构成逆时针回路时取+ , 顺时针时取 -。

  
另外在求解的过程中,不需要考虑点的输入顺序是顺时针还是逆时针,相除后就抵消了。

方法:

(1).以多边形的一个顶点O为原点(可以选输入的第一个点作为原点),作连接O与其他所有非相邻顶点的线段,将多边形(n条边)分为n-2个三角形。
多边形分解

(2).求每个三角形的面积和重心
设其中一个三角形的重心为G(cx,cy),顶点坐标分别为A1(x1,y1),A2(x2,y2),
A3(x3,y3),则有cx = (x1+x2+x3) / 3 ; cy = (y1+y2+y3) / 3 ;
面积为S = ( (x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1) ) / 2 ;

(3).求多边形的重心
公式:cx = (∑ cx[i]*s[i]) / ∑s[i] ; cy = (∑ cy[i]*s[i] ) / ∑s[i];其中(cx[i], cy[i]), s[i]分别是所划分的第i个三角形的重心坐标和面积。另外,在(2)中求每个重心坐标时要除以3,实际上不需要在求每个三角形坐标时都除以3,只需要求出∑ cx[i]*s[i]后一次性除以3即可。





HDU 1115

Lifting the Stone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.

Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.

Sample Input
2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

Sample Output
0.00 0.00
6.00 6.00



题解:多边形重心模板题。


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct Node
{
  double x,y;
};
int t,n;

double Area(Node p0,Node p1,Node p2)
{
  double area=0;
  area=p0.x*p1.y+p1.x*p2.y+p2.x*p0.y-p1.x*p0.y-p2.x*p1.y-p0.x*p2.y;
  return area/2;
}

int main()
{
  scanf("%d",&t);
  while(t--)
  {
    Node p0,p1,p2;
    double sumarea=0,sumx=0,sumy=0;
    scanf("%d",&n);
    scanf("%lf%lf",&p0.x,&p0.y);
    scanf("%lf%lf",&p1.x,&p1.y);
    for(int i=3;i<=n;i++)
    {
      scanf("%lf%lf",&p2.x,&p2.y);
      double area=Area(p0,p1,p2);//求新添三角形的面积
      sumarea+=area;
      sumx+=(p0.x+p1.x+p2.x)*area;求∑cx[i]*s[i]和∑cy[i]*s[i]
      sumy+=(p0.y+p1.y+p2.y)*area;
      p1=p2;//求总面积
    }
    printf("%.2f %.2f\n",sumx/sumarea/3,sumy/sumarea/3);
  }
  return 0;
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值