HDU 2845 Beans


传送门:HDU 2845


Beans
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Bean-eating is an interesting game, everyone owns an MN matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 11 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
在这里插入图片描述
Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn’t beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

Sample Output
242





题意:
给你一个m*n的数组,每个单位都有各自的豆子数,要你求你能吃到的最大的豆子数。
有个限制条件:选择吃(x,y)的豆子,就不能吃上面一行和下面一行的豆子,还有(x,y+1)和(x,y-1)的豆子。


题解:
用两次dp,第一次求每一行能吃到的最大豆子数;第二次求m行能吃到的最大豆子数。
第一次定义dp[i][0]表示前i列,第i列不吃,能吃到的最多豆子数;dp[i][1]表示前i列,第i列吃,能吃到的最多豆子数。
转移方程:
dp[i][0]=max(dp[i-1][0],dp[i-1][1]);
dp[i][1]=dp[i-1][0]+a[x][i];(a[x][i]表示第x行i列的豆子数)

第二次将第一次的列改为行即可。





AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=220000;
vector<int> v[N];
int m,n;
int dp[N][2],a[N];
int main()
{
  int x;
  while(~scanf("%d%d",&m,&n))
  {
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=m;i++) v[i].clear();//清空容器
    for(int i=0;i<m;i++)
    {
      for(int j=0;j<n;j++)
      {
        scanf("%d",&x);
        v[i+1].push_back(x);
      }
    }
    for(int i=1;i<=m;i++)
    {
      dp[0][1]=v[i][0];//不能在里面用memset初始化,否则会超时
      dp[0][0]=0;
      int len=v[i].size();
      for(int j=1;j<len;j++)
      {
        dp[j][1]=dp[j-1][0]+v[i][j];
        dp[j][0]=max(dp[j-1][0],dp[j-1][1]);
      }
      a[i]=max(dp[len-1][1],dp[len-1][0]);
    }
    int maxn=0;
    memset(dp,0,sizeof(dp));
    a[0]=0;
    dp[1][1]=a[1];
    for(int i=2;i<=m;i++)
    {
      dp[i][1]=dp[i-1][0]+a[i];
      dp[i][0]=max(dp[i-1][1],dp[i-1][0]);
    }
    maxn=max(dp[m][1],dp[m][0]);
    printf("%d\n",maxn);
  }
  return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值