1065  A+B and C (64bit) (20分)

A+B and C (64bit) 

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

分析 c++:

因为A、B的大小为 [-2^63, 2^63],用 long long 存储A和B的值,以及他们相加的值sum:

如果A > 0, B < 0 或者 A < 0, B > 0,sum是不可能溢出的

如果A > 0, B > 0,sum可能会溢出,sum范围理应为(0, 2^64 – 2],溢出得到的结果应该是[-2^63, -2]是个 负数,所以sum < 0时候说明溢出了

如果A < 0, B < 0,sum可能会溢出,同理,sum溢出后结果是大于0的,所以sum > 0 说明溢出了

c++ 代码

#include<cstdio>
using namespace std;
int main(){
	int n;
	scanf("%d", &n);
	long long a, b, c;
	for(int i = 0; i < n; i++){
		scanf("%lld%lld%lld", &a, &b, &c);
		long long sum = a+b;
		if(a>0 && b>0 && sum<0){
			printf("Case #%d: true\n", i+1);
		}
		else if(a<0 && b<0 && sum>=0){
			printf("Case #%d: false\n", i+1);
		}
		else if(sum > c){
			printf("Case #%d: true\n", i+1);
		}
		else{
			printf("Case #%d: false\n", i+1);
		}
	}
	return 0;
}

分析 Python:如果使用Python,就不用考虑溢出问题,直接计算比较即可; 

Python 代码

def main():
    num = int(input())
    case = 1
    for x in range(num):
        line = input().split(" ")
        a = int(line[0])
        b = int(line[1])
        c = int(line[2])
        if a+b >c:
            print('Case #{}: true'.format(case))
        else:
            print('Case #{}: false'.format(case))
        case += 1
if __name__ == "__main__":
    main()

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值