1065. A+B and C (64bit) (20)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

判断a+b是否大于c。这里需要注意的是a+b可能溢出,如果a大于0且b大于0,但相加得到的却是小于等于0的说明是正溢出,这时肯定比c大(因为c肯定在long long的范围内)。如果a小于0且b小于0,但相加得到的却是大于等于0的说明是负溢出,这是肯定比c小。其他情况就和平常计算一样。这里还要注意a+b要赋值给一个变量再和c比较。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		long long a,b,c;
		scanf("%lld %lld %lld",&a,&b,&c);
		bool istrue;
		long long res=a+b;
		if(a>0&&b>0&&res<=0) istrue=true;
		else if(a<0&&b<0&&res>=0) istrue=false;
		else if(res>c) istrue=true;
		else istrue=false;
		printf("Case #%d: %s\n",i,istrue?"true":"false");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 8
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 8
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值