Dining

题目

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: NF, and D 
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fiintegers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

样例

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

提示

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

这道题一开始是不会做的,因为想要用二分图匹配,但是这里有两个东西,所以不能用,只能用最大流,但是这个图不会建,于是查了一下kuangbin大佬的博客,发现可以把牛拆点成两个点,两个点之间有一个管道,容量是1!加个源点和汇点。源点与食物、饮料和汇点的边容量都是1,表示每种食物和饮料只有一个。这样话完全是最大流问题了。。。。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <string.h>
#define INF 0x3f3f3f3f
#define maxn 500
typedef long long ll;
using namespace std;
int g[maxn][maxn];//存边的容量,没有边的初始化为0
int path[maxn], flow[maxn], bg, ed;
int n;//点的个数,编号0-n.n包括了源点和汇点。
queue<int>q;
int bfs(){
	int i, t;
	while (!q.empty())q.pop();//把清空队列
	memset(path, -1, sizeof(path));//每次搜索前都把路径初始化成-1
	path[bg] = 0;
	flow[bg] = INF;//源点可以有无穷的流流进
	q.push(bg);
	while (!q.empty()){
		t = q.front();
		q.pop();
		if (t == ed)
			break;
		//枚举所有的点,如果点的编号起始点有变化可以改这里
		for (i = 0; i <= n; i++){
			if (i != bg && path[i] == -1 && g[t][i]){
				flow[i] = flow[t] < g[t][i] ? flow[t] : g[t][i];
				q.push(i);
				path[i] = t;
			}
		}
	}
	if (path[ed] == -1)
		return -1;//即找不到汇点上去了。找不到增广路了
	return flow[ed];
}
int Edmonds_Karp(){
	int maxflow = 0;
	int step, now, pre;
	while ((step = bfs()) != -1){
		maxflow += step;
		now = ed;
		while (now != bg){
			pre = path[now];
			g[pre][now] -= step;
			g[now][pre] += step;
			now = pre;
		}
	}
	return maxflow;
}
int main()
{
	int N, F, D;
	while (scanf("%d%d%d", &N, &F, &D) != EOF)
	{
		memset(g, 0, sizeof(g));
		n = F + D + 2 * N + 1;
		bg = 0;
		ed = n;
		for (int i = 1; i <= F; i++)
			g[0][i] = 1;
		for (int i = F + 2 * N + 1; i <= F + 2 * N + D; i++)
			g[i][n] = 1;
		for (int i = 1; i <= N; i++)
			g[F + 2 * i - 1][F + 2 * i] = 1;
		int k1, k2;
		int u;
		for (int i = 1; i <= N; i++){
			scanf("%d%d", &k1, &k2);
			while (k1--){
				scanf("%d", &u);
				g[u][F + 2 * i - 1] = 1;
			}
			while (k2--){
				scanf("%d", &u);
				g[F + 2 * i][F + 2 * N + u] = 1;
			}
		}
		printf("%d\n", Edmonds_Karp());
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值