Wireless Network

题目

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

样例

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

这应该就是一道典型的模板题目,但是这道题目有坑,那就是不能把数组的第一个定位1,电脑的编号是0开始的,所以要从0开始存数组,就因为这个原因wa了好多次!

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <string.h>
#include <string>
typedef long long ll;
#define INF 0x3f3f3f3f
using namespace std;
#define maxn 100005
int n, d;
int dx[maxn];
int dy[maxn];
int par[maxn];
int pairs[maxn];

void init(int n) {
	for (int i = 0; i < n; ++i) par[i] = i;
}

int find(int x) {
	if (x == par[x])
		return x;
	return par[x] = find(par[x]);
}

void unite(int x, int y){
	x = find(x);
	y = find(y);
	if (x == y)
		return;
	par[x] = y;
}

double dis(int a, int b) {
	return sqrt((double)((dx[a] - dx[b]) * (dx[a] - dx[b]) + (dy[a] - dy[b]) * (dy[a] - dy[b])));
}

int main() {
	ios::sync_with_stdio(false);
	memset(pairs, 0, sizeof(pairs));
	cin >> n >> d;
	for (int i = 0; i < n; ++i)
		cin >> dx[i] >> dy[i];
	init(n);
	int p, q, len = 0;
	char op;
	while (cin >> op) {
		if (op == 'O') {
			cin >> p;
			p--;
			pairs[len++] = p;
			for (int i = 0; i < len; ++i)
				if (dis(pairs[i], p) <= (double)d)
					unite(pairs[i], p);
		}
		else {
			cin >> p >> q;
			p--; q--;
			if (find(p) == find(q))
				cout << "SUCCESS" << endl;
			else
				cout << "FAIL" << endl;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值