【PTA Advanced】1152 Google Recruitment(C++)

文章描述了一道与Google2004年招聘相关的数学编程问题,要求找到自然常数e连续数字中的第一个指定长度的素数。提供的解决方案包括将数字以字符串处理,遍历截取并检验是否为素数。如果找不到这样的素数,则输出404。
摘要由CSDN通过智能技术生成

目录

题目

Input Specification:

Output Specification:

Sample Input 1:

Sample Output 1:

Sample Input 2:

Sample Output 2:

 思路

代码


题目

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

 思路

难度评级:⭐️

步骤:

1. 数字以字符串的方式存储

2. 从字符串的开头开始遍历,每次截取k的长度的字符串,函数:

s.substr(pos, n) // 截取s中从pos开始(包括0)的n个字符的子串,并返回

 3. 字符串类型转换为int型,然后检查其是否为素数,字符串转换为int函数:

int num = stoi(str);

Dev-c++使用stoi时可能有问题,解决方法参考:Dev-c++下'stoi' was not declared in this scope解决办法 

代码

#include <iostream>
#include <cmath>

using namespace std;

bool isPrime(int n) {
	if(n<=1) return false;
	for(int i=2;i<=sqrt(n);i++) {
		if(n%i==0) return false;
	}
	return true;
}

int main(int argc, char** argv) {
	int l,k;// l-数字的长度;k-prime的长度 
	string n; 
	cin>>l>>k>>n;
	
	for(int i=0;i<=l-k;i++) {
		string str=n.substr(i,k);
		if(isPrime(stoi(str))) {
			cout<<str;
			return 0;
		}
	}
	cout<<"404";
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值