【PTA Advanced】1148 Werewolf - Simple Version(C++)

目录

题目

Input Specification:

Output Specification:

Sample Input 1:

Sample Output 1:

Sample Input 2:

Sample Output 2 (the solution is not unique):

Sample Input 3:

Sample Output 3:

思路

代码


题目

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

思路

难度评级:⭐️⭐️⭐️⭐️

难度评四颗星的原因是,我拿到这题时一点思路也没有,不知道如何下手,看了PAT 1148 Werewolf  柳婼 の blog的代码才知道其实是枚举每一种狼人情况的方法,并且柳神非常巧妙地运用了正负数乘积为负数这一点作为一些 if 的判断,非常值得学习借鉴。

代码

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main(int argc, char** argv) {
	int n;
	cin>>n;
	
	vector<int> words(n+1);
	for(int i=1;i<=n;i++) cin>>words[i];
	
	// 枚举每一种狼人情况 
	for(int i=1;i<n;i++) {
		for(int j=i+1;j<=n;j++) {
			vector<int> identity(n+1, 1);// 标识每个人的身份,1表示村民,-1表示狼人 
			vector<int> liars; 
			
			// 假设用户i和用户j为狼人
			identity[i]=-1;
			identity[j]=-1;
			// 遍历每个人说的话,判断他是否说谎 
			for(int k=1;k<=n;k++) {
				if(words[k]*identity[abs(words[k])]<0) {
					liars.push_back(k);
				}
			}
			// 检查说谎的人是否有两个人,且一个是狼人一个村民
			if(liars.size()==2&&identity[liars[0]]*identity[liars[1]]<0) {
				cout<<i<<" "<<j;
				return 0;
			} 
		}
	}
	
	cout<<"No Solution";
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值