【PTA Advanced】1151 LCA in a Binary Tree(C++)

文章描述了一种算法问题,即在给定二叉树的中序和前序遍历序列的情况下,找到两个节点的最低公共祖先。解决方案包括使用深度优先搜索重建二叉树并找出节点路径,然后找到这些路径的最深交点作为公共祖先。对于不存在的节点或同一节点的情况,也有相应的处理方式。
摘要由CSDN通过智能技术生成

目录

题目

Input Specification:

Output Specification:

Sample Input:

Sample Output:

思路

代码(我的思路)


题目

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

思路

难度评级:⭐️⭐️

我的思路:

1. 对中序和前序遍历序列进行dfs来确定每个结点的父节点是谁;

2. 遍历需要test的u和v,统计u、v向上找一直到根结点的路径path

3. 从u、v path中的根结点(最后一个元素)开始向前同步遍历,统计它们开始出现分叉前的一个结点,就是u、v最深的共同祖先

但是这个思路,并不是最优,看了柳神的思路,跑了一下代码,耗时更短,指路:PAT 1151 LCA in a Binary Tree 柳婼

需要注意的点:

如果给出的u和v是同一个结点,那么应该输出的是"u is an ancestor of v.",而不是"LCA of u and v is u."

代码(我的思路)

#include <iostream>
#include <vector>
#include <map>

using namespace std;

vector<int> inOrder,preOrder;
map<int,int> fatherMap;

void dfs(int preL,int preR, int inL,int inR, int father) {
	if(preL>preR) return;
	
	// 确定子树根结点的father 
	int root=preOrder[preL];
	fatherMap[root]=father;
	
	// 寻找root在inOrder中的位置
	int index;
	for(index=inL;index<=inR;index++) {
		if(inOrder[index]==root) break;
	} 
	
	// 以同样的方式处理其左右子树
	dfs(preL+1,preL+index-inL, inL,index-1, root);
	dfs(preL+index-inL+1,preR, index+1,inR, root); 
}

void findPath(int node,vector<int> &path) {
	while(node!=-1) {
		path.push_back(node);
		node=fatherMap[node];
	}
}

int main(int argc, char** argv) {
	int m,n;
	cin>>m>>n;
	
	inOrder.resize(n);
	preOrder.resize(n);
	for(int i=0;i<n;i++) cin>>inOrder[i];
	for(int i=0;i<n;i++) cin>>preOrder[i];
	
	// 寻找每个结点的父节点 
	dfs(0,n-1, 0,n-1, -1); 
	
	for(int i=0;i<m;i++) {
		int u,v;
		cin>>u>>v;
		
		// 判断u、v是否存在 
		if(fatherMap.count(u)==0&&fatherMap.count(v)==1) {
			printf("ERROR: %d is not found.\n",u);
		} else if (fatherMap.count(u)==1&&fatherMap.count(v)==0){
			printf("ERROR: %d is not found.\n",v);
		} else if (fatherMap.count(u)==0&&fatherMap.count(v)==0){
			printf("ERROR: %d and %d are not found.\n",u,v);
		} else {			
			// u、v都存在时,分别寻找从其向上一路找到根结点的线路
			vector<int> uPath,vPath;
			findPath(u,uPath); 
			findPath(v,vPath);
			
			// 从uPath和vPath的根结点部分开始向前遍历,找到最深的common ancestor
			int j=uPath.size()-1,k=vPath.size()-1,deepestAncestor;
			for(;j>=0&&k>=0;j--,k--) {
				if(uPath[j]==vPath[k]) deepestAncestor=uPath[j];
				else break;
			}
			
			// u是v的father或v是u的father时
			if(deepestAncestor==v) printf("%d is an ancestor of %d.\n",v,u);
			else if (deepestAncestor==u) printf("%d is an ancestor of %d.\n",u,v);
			else printf("LCA of %d and %d is %d.\n",u,v,deepestAncestor);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值