简单搜索 - Catch That Cow

Description:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Code

#include <iostream>
#include <stdio.h>
#include <queue>
using namespace std;

const int MAX_N=2e5;

int vis[MAX_N]={0};
//int vis[MAX_N][MAX_N][MAX_N]={0,0};

struct node{
    int data;
    int step;
    node(int i=0,int j=0){
        data=i;
        step=j;
    }
};


int bfs(int n, int k){
    node s = node(n,0);
    queue<node> q;
    q.push(s);
    vis[n]=1;
    while(!q.empty()){
        node tmp = q.front();
        q.pop();

        if(tmp.data == k) return tmp.step;

        if(tmp.data-1>=0&&!vis[tmp.data-1]){
            vis[tmp.data-1]=1;
            q.push(node(tmp.data-1,tmp.step+1));
        }

        if(tmp.data+1<MAX_N&&!vis[tmp.data+1]){
            vis[tmp.data+1]=1;
            q.push(node(tmp.data+1,tmp.step+1));
        }

        if(tmp.data*2<MAX_N&&!vis[tmp.data*2]){
            vis[tmp.data+1]=1;
            q.push(node(tmp.data*2,tmp.step+1));
        }

    }
    return -1;
}

int main() {
    //freopen("/Users/guoyu/Desktop/algorithm/in.txt", "r", stdin);
    int n,k;
    cin>>n>>k;
    int ans = bfs(n,k);
    cout<<ans<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值