PAT 甲级---1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

#include <iostream>
#include <string>
#include <vector>
using namespace std;

struct ScoreData {
	string StuID;
	int CS;
	int Math;
	int English;
	int Average;
	int BestRank;
	char Item;
};

int Mininum(int A, int B, int C, int D)
{
	int E, F;
	E = A < B ? A : B;
	F = C < D ? C : D;
	return E < F ? E : F;
}
int main(void)
{
//	freopen("input.txt", "r", stdin);
	int StudentNum, ToCheckNum,TotalScore;
	cin >> StudentNum >> ToCheckNum;
	vector<ScoreData> Data(StudentNum);
	for (int i = 0; i < StudentNum; ++i) {
		cin >> Data[i].StuID >> Data[i].CS >> Data[i].Math >> Data[i].English;
		TotalScore = Data[i].CS + Data[i].Math + Data[i].English;
		Data[i].Average =  TotalScore / 3;
		if (TotalScore - Data[i].Average * 3 > 1)Data[i].Average++;
		Data[i].BestRank = StudentNum;
	}
	int CSRank, MathRank, EnglishRank, AverageRank,BestRank;
	char Item;
	for (int i = 0; i < StudentNum; ++i) {
		CSRank = MathRank = EnglishRank = AverageRank = 1;
		for (int j = 0; j < StudentNum; ++j) {
			if (i == j) continue;
			if (Data[i].Math < Data[j].Math) MathRank++;
			if (Data[i].CS < Data[j].CS) CSRank++;
			if (Data[i].English < Data[j].English) EnglishRank++;
			if (Data[i].Average < Data[j].Average) AverageRank++;
		}
		BestRank = Mininum(MathRank, CSRank, EnglishRank, AverageRank);
		if (AverageRank == BestRank) Item = 'A';
		else if (CSRank == BestRank) Item = 'C';
		else if (MathRank == BestRank) Item = 'M';
		else Item = 'E';
		Data[i].BestRank = BestRank;
		Data[i].Item = Item;
	}
	string ToCheck;
	int i, j;

	for (i = 0; i < ToCheckNum; ++i) {
		cin >> ToCheck;
		for ( j = 0; j < StudentNum; ++j) {
			if (ToCheck == Data[j].StuID) {
				cout << Data[j].BestRank << " " << Data[j].Item << endl;
				break;
			}			
		}
		if (j == StudentNum) cout << "N/A" << endl;
	}

//	fclose(stdin);
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值