1020 Tree Traversals (25 分)

1020 Tree Traversals (25 分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

紧跟柳神的步伐,这个题知道什么原理,确实不知道怎么写代码,还是柳神强啊!

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

struct Data {
	int Item, Level;
};

int Total;
vector<int> PostOrder, InOrder;
vector<Data> LevelOrder;

/*
-----------------------------------------

-----------------------------------------
*/
bool cmp(Data A, Data B)
{
	return A.Level < B.Level;
}

void PreOrder(int Root,int Start,int End,int Level)
{
	if (Start > End) return;
	int i = Start;
	while (i < End && InOrder[i] != PostOrder[Root]) i++;
	LevelOrder.push_back({ PostOrder[Root],Level });
	PreOrder(Root - (End - i) - 1, Start, i - 1, 2 * Level + 1);
	PreOrder(Root - 1, i + 1, End, 2 * Level + 2);
}
int main(void)
{
//	freopen("input.txt", "r", stdin);
	cin >> Total;
	PostOrder.resize(Total);
	InOrder.resize(Total);
	for (int i = 0; i < Total; ++i)
		cin >> PostOrder[i];
	for (int i = 0; i < Total; ++i)
		cin >> InOrder[i];
	PreOrder(Total - 1, 0, Total - 1, 0);
	sort(LevelOrder.begin(), LevelOrder.end(), cmp);
	for (int i = 0; i < Total; ++i) {
		if (i != 0) cout << " ";
		cout << LevelOrder[i].Item;
	}	
//	fclose(stdin);
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值