1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10
​4
​​ ) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

相比于1014,这道题似乎要简单一点,相当于是黄线里面只有一排。
注意:只要顾客在17点前到达,那么一定会被服务。
最后一个测试点中的LastFinishTime 可能会大于24点,所以在找最小的窗口时应该将MinTime初始化更大。
或者直接用LastFinishTime[0]为初值,同时从1开始循环,找最小的时间。
在这里插入图片描述

#include <iostream>
#include <vector>
#include<algorithm>

using namespace std;
struct CustomerData{
	int ArriveTime;
	int ProcessTime;
	int WaitingTime = 0;
};

bool cmp(CustomerData A, CustomerData B)
{
	return A.ArriveTime < B.ArriveTime;
}

int main(void)
{
	freopen("input2.txt", "r", stdin);
	int CustomerNum, WindowNum;
	int Hour, Minute, Second, Time;
	cin >> CustomerNum >> WindowNum;
	vector<int> LastFinishTime(WindowNum,28800);	//存储每一个当前窗口结束的时间
	CustomerData TempCust;							//用以帮助入最小堆
	vector<CustomerData>Customers;
	for (int i = 0; i < CustomerNum; ++i) {
		scanf("%d:%d:%d %d", &Hour, &Minute, &Second, &Time);
		TempCust.ArriveTime = Hour * 60 * 60 + Minute * 60 + Second;
		TempCust.ProcessTime = Time * 60;
		if (TempCust.ArriveTime <= 17 * 60 * 60)			//剔除下午5点以后开始排队的顾客
			Customers.push_back(TempCust);
	}
	sort(Customers.begin(), Customers.end(), cmp);
	int CountWindowNum = 0,TotalWaitTime = 0,MinTime;
	for (unsigned int i = 0; i < Customers.size(); ++i) {
		MinTime = 100000;		//若此处MinTime初始化为86400,即24点,则最后测试点过不去,改成更大的就可以过去了
		CountWindowNum = 0;
		for (int j = 0; j < WindowNum; ++j) {
			if (MinTime > LastFinishTime[j]) {
				MinTime = LastFinishTime[j];
				CountWindowNum = j;
			}
		}
		if (Customers[i].ArriveTime > LastFinishTime[CountWindowNum]) {
			Customers[i].WaitingTime = 0;
			LastFinishTime[CountWindowNum] = Customers[i].ArriveTime + Customers[i].ProcessTime;
		}
		else {
			Customers[i].WaitingTime = LastFinishTime[CountWindowNum] - Customers[i].ArriveTime;
			LastFinishTime[CountWindowNum] += Customers[i].ProcessTime;
		}
		/*若在17点前到达的顾客等到17点还没有没服务就直接离开,那么可以加上以下两行*/
	//	if (LastFinishTime[CountWindowNum] > 17 * 60 * 60)
	//		LastFinishTime[CountWindowNum] = 17 * 60 * 60;
		TotalWaitTime += Customers[i].WaitingTime;		
	}
	if (!Customers.size()) printf("0.0\n");
	else printf("%.1lf", 1.0 * TotalWaitTime / 60 / Customers.size());
	fclose(stdin);
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值