A Simple Math Problem HDU - 1757(递推构造矩阵快速幂)

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
Output
For each case, output f(k) % m in one line.
Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
Sample Output
45
104

关键在于递推式矩阵的构造

递推式构造矩阵之前我总结过方法:矩阵快速幂和递推式构造常矩阵总结

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
 using namespace std;
 typedef long long ll;
 const int mod=9973;
struct node
{
    ll ma[11][11];
};
 ll m;
 node mul(node a,node b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
    for(int i=1;i<=10;i++)
        for(int j=1;j<=10;j++)
         for(int k=1;k<=10;k++)
            ans.ma[i][j]=(ans.ma[i][j]+a.ma[i][k]*b.ma[k][j])%m;
    return ans;
 }
 node pow(node a,int b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
     for(int i=1;i<=10;i++) ans.ma[i][i]=1;
     while(b)
     {
         if(b&1) ans=mul(ans,a);
         a=mul(a,a);
         b>>=1;
     }
     return ans;
 }
 int main()
 {
     ll k;
     while(cin >>k>>m)
     {
         if(k<10)
         {
             cout <<k%m<<endl;
             break;
         }
         node a,b;
         memset(a.ma,0,sizeof a.ma);
         int temp=1;
         for(int i=1; i<=10; i++)  b.ma[i][1]=9-i+1;
         for(int i=1;i<=10;i++) cin >>a.ma[1][i];
         for(int i=2;i<=10;i++) a.ma[i][temp++]=1;
//         node b;
//         b
         node ans=pow(a,k-9);
         ans=mul(ans,b);
         cout <<(ans.ma[1][1]+m)%m<<endl;
     }
     return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值