Recursive sequence HDU 5950

继上一篇简单总结》》》》**矩阵快速幂和递推式构造常系数之后今天写一道简单的又不简单的题回忆一下;
这道题wa的人估计都是const int mod=2147493647 了吧 …
要用long long
题源:Recursive sequence

题目
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
Sample Input
2
3 1 2
4 1 10
Sample Output
85
369

Hint
In the first case, the third number is 85 = 21十2十3^4.
In the second case, the third number is 93 = 2
1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

题意

题目的大意就是给了一个递推式 F(n)=F(n-1)+2F(n-2)+i^4;F(1) = a,F(2) = b;给定一个N,求F(N)等于多少?

由于N很大,直接递推肯定超时,所以要用到矩阵快速幂的知识log(n)的复杂度来解决。问题的关键就在于如何构造矩阵上,可以看出本题的递推公式是一个非线性的式子,所以要将非线性的部分展开为线性的。
首先构造矩阵递推式;

在这里插入图片描述

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
 using namespace std;
 typedef long long ll;
 const ll mod=2147493647;
struct node
{
    ll ma[11][11];
};
 node mul(node a,node b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
    for(int i=0;i<7;i++)
        for(int j=0;j<7;j++)
         for(int k=0;k<7;k++)
            ans.ma[i][j]=(ans.ma[i][j]+a.ma[i][k]*b.ma[k][j])%mod;
    return ans;
 }
 node pow(node a,int b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
     for(int i=0;i<7;i++) ans.ma[i][i]=1;
     while(b)
     {
         if(b&1) ans=mul(ans,a);
         a=mul(a,a);
         b>>=1;
     }
     return ans;
 }
int main(){

    node a;
    memset(a.ma,0,sizeof(a.ma));
    a.ma[0][1] = 1;
    a.ma[1][1] = a.ma[1][2] = a.ma[1][6] = 1;
    a.ma[2][2] = a.ma[2][6] = 1;
    a.ma[1][0] = 2; a.ma[1][3] = a.ma[1][5] = a.ma[2][3] = a.ma[2][5] = 4;
    a.ma[1][4] = a.ma[2][4] = 6;
    a.ma[3][3] = a.ma[4][4] = a.ma[5][5] = a.ma[6][6] = 1;
    a.ma[3][6] = a.ma[4][6] = a.ma[5][6] = 1;
    a.ma[3][4] = a.ma[3][5] = 3;
    a.ma[4][5] = 2;
    int t;
    scanf("%d",&t);
    ll n,aa,bb;
    node b;
    while(t--){
        scanf("%lld%lld%lld",&n,&aa,&bb);
        if(n==1){
            printf("%lld\n",aa%mod);
        }
        else if(n==2){
            printf("%lld\n",bb%mod);
        }
        else{

            node ans = pow(a,n-2);
            ll ANS = 0;
            ANS = (ANS+ans.ma[1][0]*aa)%mod;
            ANS = (ANS+ans.ma[1][1]*bb)%mod;
            ANS = (ANS+ans.ma[1][2]*16)%mod;
            ANS = (ANS+ans.ma[1][3]*8)%mod;
            ANS = (ANS+ans.ma[1][4]*4)%mod;
            ANS = (ANS+ans.ma[1][5]*2)%mod;
            ANS = (ANS+ans.ma[1][6]*1)%mod;
            printf("%I64d\n",ANS);
        }
    }
    return 0;
}

wrong answer代码:(至今我都不知道哪里错了)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
 using namespace std;
 typedef long long ll;
 const int mod=2147493647;
struct node
{
    ll ma[11][11];
};
 node mul(node a,node b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
    for(int i=0;i<7;i++)
        for(int j=0;j<7;j++)
         for(int k=0;k<7;k++)
            ans.ma[i][j]=(ans.ma[i][j]+a.ma[i][k]*b.ma[k][j])%mod;
    return ans;
 }
 node pow(node a,int b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
     for(int i=0;i<7;i++) ans.ma[i][i]=1;
     while(b)
     {
         if(b&1) ans=mul(ans,a);
         a=mul(a,a);
         b>>=1;
     }
     return ans;
 }
int main(){

    node a;
    memset(a.ma,0,sizeof(a.ma));
    a.ma[0][1] = 1;
    a.ma[1][1] = a.ma[1][2] = a.ma[1][6] = 1;
    a.ma[2][2] = a.ma[2][6] = 1;
    a.ma[1][0] = 2; a.ma[1][3] = a.ma[1][5] = a.ma[2][3] = a.ma[2][5] = 4;
    a.ma[1][4] = a.ma[2][4] = 6;
    a.ma[3][3] = a.ma[4][4] = a.ma[5][5] = a.ma[6][6] = 1;
    a.ma[3][6] = a.ma[4][6] = a.ma[5][6] = 1;
    a.ma[3][4] = a.ma[3][5] = 3;
    a.ma[4][5] = 2;
//    for(int i=0;i<7;i++){//可以把矩阵输出看一看对不对
//        for(int j=0;j<7;j++)
//        {
//            printf("%lld ",a.ma[i][j]);
//        }
//        puts("");
//    }
    int t;
    scanf("%d",&t);
    ll n,aa,bb;
    node b;
    while(t--){
        scanf("%lld%lld%lld",&n,&aa,&bb);
        if(n==1){
            printf("%lld\n",aa%mod);
        }
        else if(n==2){
            printf("%lld\n",bb%mod);
        }
        else{
            memset(b.ma,0,sizeof(b.ma));
            b.ma[0][0]=aa;
            b.ma[1][0]=bb;
            b.ma[2][0]=16;
            b.ma[3][0]=8;
            b.ma[4][0]=4;
            b.ma[5][0]=2;
            b.ma[6][0]=1;
//            for(int i=0;i<7;i++){可以把矩阵输出看一看对不对
//                for(int j=0;j<7;j++)
//                {
//                    printf("%lld ",b.ma[i][j]);
//                }
//                puts("");
//            }
            node ans=pow(a,n-2);
            ans=mul(ans,b);
            printf("%lld\n",ans.ma[1][0]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值