Largest Rectangle in a Histogram 动态规划

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0

Sample Output
8 4000

如果左边一列比这一列高,那么这一列对应的矩阵就往左一格,同时我们想到,这一列矩阵的最左边,其实就是左边那个比它的列的最左。
右边同理,
这样l,r分别是这一列对应最大矩阵的左右,求面积就是这一列高*(r-l+1)

#include<bits/stdc++.h>
using namespace std;
const int N=1e7+5;
typedef long long ll;
int t;
ll ans=0;
ll a[N];
ll r[N],l[N];
int main() {
	while(cin>>t,t) {
		ans=0;
		for(int i=1; i<=t; i++) {
			cin>>a[i];
			l[i]=r[i]=i;
		}
		a[0]=a[t+1]=-1;
		for(int i=1; i<=t; i++) {
			while(a[l[i]-1]>=a[i]) {
				l[i]=l[l[i]-1];
			}
		}
		for(int i=t; i>=1; i--) {
			while(a[r[i]+1]>=a[i])
				r[i]=r[r[i]+1];
		}
		for(int i=1;i<=t;i++){
			ans=ans<((r[i]-l[i]+1)*a[i])?((r[i]-l[i]+1)*a[i]):ans;
		}
		cout<<ans<<endl;
	}
	return 0;
}

如果懂了,可以去试着敲一下hdu1505 City Game 最大子矩阵、动态规划

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值