Rightmost Digit hdu

37 篇文章 0 订阅

Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74332 Accepted Submission(s): 27415

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1021 1019 1071 1108 1170

取个位数

#include<bits/stdc++.h>
using namespace std;
int  qpow(int n,int k)
{
	int ans=1,rec=n%10;
	while(k)
	{
		if(k&1) ans=ans*rec;
		ans%=10;
		k>>=1;
		rec=rec*rec%10;
	}
	return ans;
}
int main(){
	int tt;
	scanf("%d",&tt);
	for(int i=0;i<tt;i++)
	{
		int k;
		scanf("%d",&k);
		int q=qpow(k,k);
		printf("%d\n",q);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值