Sum hdu

37 篇文章 0 订阅

Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 5322 Accepted Submission(s): 2099

Problem Description

Sample Input

2

Sample Output

2
Hint

  1. For N = 2, S(1) = S(2) = 1.

  2. The input file consists of multiple test cases.

Source
2013 Multi-University Training Contest 10

费马小定理/快速幂运算
https://blog.csdn.net/codeswarrior/article/details/79867198

#include<bits/stdc++.h>
using namespace std;
const long long mod=1e9+7;	
char  r[100010];
long long qpow(long long x,long long k)
{
	long long ans=1,res=x;
	while(k)
	{
		if(k&1) ans=(ans*res)%mod;
		k>>=1;
		res=res*res%mod;
	}
	return ans;
}
int main(){
	long long n;
	while(~scanf("%s",r))
	{	n=0;
		for(int i=0;i<strlen(r);i++)
		{
			n=(n*10+r[i]-'0')%(mod-1);
		}
		long long ans=qpow(2,n-1);
		printf("%lld\n",ans);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值