hdu5776——sum

13 篇文章 0 订阅
Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 , 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO


题目大意:给一个序列,问你有没有一个字段和可以将m除尽

解题思路:例如 序列为1,2,3,4,m为4,分别求出前i项的和,sum[0]=0,sum[1]=1,sum[2]=3,sum[3]=6,sum[4]=10;他们分别对m求余为,0,1,3,2,2。其中2出现了两次,既说明sum[3],sum[4]都对m求余为2,他们都有m的倍数之外再加2,所以他们两个相减即为m的倍数。即(sum[i]-sum[j])%m==0.

代码:


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int sum[100005],cnt[5005];
int main()
{
    int t,n,m,x;
    scanf("%d",&t);
    while(t--)
    {
        memset(cnt,0,sizeof(cnt));
        scanf("%d%d",&n,&m);
        sum[0]=0,cnt[0]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            sum[i]=sum[i-1]+x;
            cnt[sum[i]%m]++;
        }
        int flag=0;
        for(int i=0;i<m;i++)
        {
            if(cnt[i]>1){
                flag=1;
                break;
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值