A - Meteor Shower的解答

A - Meteor Shower
Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

  • Line 1: A single integer: M
  • Lines 2…M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output

  • Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output
5

该题目要用优先队列求解,不用优先队列也没有关系,时间多40多ms,我开始一直TLE,就是因为我在数据被pop出来的时候才把flag标记为已读,应该在push的时候就标记,因为优先队列中会自动排序,我因为这一个小毛病整整花了2个小时,下面是我ac的代码

#include <cstdio>
#include <cstring>

#include <queue>
using namespace std;
int a[305][305];
int flag[305][305];
int xf[]={-1,0,1,0};
int yf[]={0,1,0,-1};
struct point{
	int x,y,countn;
};
bool operator < (const point &a,const point &b)
{
	return a.countn>b.countn;
} 


void Bfs(){

priority_queue <struct point> que;
	struct point P,T;
	P.x=0;
	P.y=0;
	P.countn=0;
	que.push(P);
	while(!que.empty()){
		P=que.top();
		que.pop();
		if(a[P.x][P.y]==-1){
			printf("%d\n",P.countn);
			return;
		}
		else{
			for(int i=0;i<4;i++){
				T.x=P.x+xf[i];
                T.y=P.y+yf[i];
                T.countn=P.countn+1;
				if(T.x>=0&&T.y>=0&&(a[T.x][T.y]==-1||a[T.x][T.y]>T.countn)){
				    if(!flag[T.x][T.y])				    
				    que.push(T);
				    flag[T.x][T.y]=1;			
				}
			}
		}
		
	}
	printf("-1\n");
	return ;
}
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<302;i++)
	    for(int j=0;j<302;j++){
		    a[i][j]=-1;
		    flag[i][j]=0;
	    }
		int i,j,time;
		for(int k=0;k<n;k++){
		scanf("%d%d%d",&i,&j,&time);
		if(a[i][j]==-1) a[i][j]=time;
		else  a[i][j]=min(time,a[i][j]);
		for(int l=0;l<4;++l)
		{
			int nx=i+xf[l];
				int ny=j+yf[l];
				if(nx>=0&&ny>=0)
				{
					if(a[nx][ny]==-1)
						a[nx][ny]=time;
					else
						a[nx][ny]=min(time,a[nx][ny]); 
				}	
		}
		}
		Bfs(); 
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值