PAT A1065 A+B and C (64bit)

Given three integers A, B and C in [−2的63次方​​ ,2的63次方​​ ], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

接下来时AC代码:

#include <stdio.h>
#include <stdbool.h>
int main(int argc, char *argv[]) {
	int T,count=1;
	long long a,b,c;
	long long result;
	bool flag;
	scanf("%d",&T);
	while(T--){
		scanf("%lld%lld%lld",&a,&b,&c);
		result=a+b;
		if(a>0&&b>0&&result<0){
			flag=true;         //正溢出为true 
		}else if(a<0&&b<0&&result>=0){
			flag=false;        //负溢出为false 
		}else if(result>c){
			flag=true;         //无溢出时,正常比较 
		}else{
			flag=false;		   //无溢出时,正常比较 
		}
		if(flag==true){
			printf("Case #%d: true\n",count++);
		}else{
			printf("Case #%d: false\n",count++);
		}
	}
	return 0;
}

注意:
1.这个题目的主要意图是让我们考虑溢出
2.计算机组成原理中指出,两个正数之和等于复数或者两个负数之和等于正数,就是溢出
3.a>0,b>0,a+b<0的时候为正溢出,结果为true
4.a<0,b<0,a+b>=0的时候为负溢出,结果为false
5.没有发生溢出时正常结算
6.a+b必须放到longlong类型变量中才可以和c进行比较,直接用a+b和c比较会造成数据错误

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

纳萨斯瓦德

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值