PAT:A1065 A+B and C (64bit) (20 分)

PAT:A1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

思路:

1.输入三个数,如果A + B > C 输出 'Case #X: true',其他情况下输出'Case #X: false'

2.注意,A,B,C的范围时[-2^64, 2^64],A+B有可能会超出long long的范围。

3.如果超出了正数的范围,那么A+B时<0的,如果超出了负数的范围,那么A+B是>= 0的。

代码:

C/C++:

#include<stdio.h>

int main() {
	int T, t = 1;
	scanf("%d", &T);
	for(int i = 1; i <= T; i++) {
		long long a, b,c;
		scanf("%lld%lld%lld", &a, &b, &c);
		long long res = a + b;
		bool flag;
		if(res < 0 && a > 0 && b > 0) flag = true;
		else if(res >= 0 && a < 0 && b < 0) flag = false;
		else if(res > c) flag = true;
		else flag = false;
		if(flag == true) {
			printf("Case #%d: true\n", t++);
		} else {
			printf("Case #%d: false\n", t++);
		}
	}
	return 0;
} 

Java:

import java.util.Scanner;

/**
 * @author 余修文
 * @date 2018/9/20 9:23
 */
public class Main {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int t;
        long a, b, c, count;
        t = in.nextInt();
        for(int i = 1; i <= t; i++) {
            boolean isFlag;
            a = in.nextLong();
            b = in.nextLong();
            c = in.nextLong();
            count = a + b;
            if(count < 0 && a > 0 && b > 0) {
                isFlag = true;
            } else if(count >= 0 && a < 0 && b < 0) {
                isFlag = false;
            } else if (count > c) {
                isFlag = true;
            } else {
                isFlag = false;
            }
            if(isFlag) {
                System.out.printf("Case #%d: true\n", i);
            } else {
                System.out.printf("Case #%d: false\n", i);
            }
        }
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值