01背包

分析
01问题是典型的动态规划算法问题,动态规划算法与分治法一样,都是拆解成小问题,找出状态关系,然后用递推方法解决。为了能找出状态关系,往往需要自己定义出一个数列。在比较简单的动态规划中这个数列又往往是个二阶数组,并且二阶数组又是与算法中重要两个数据有关。本问题中最重要的两个量物品、背包重量。

定义:m[i][j]表示考虑到编号为i的物品、当背包容量为j时的最大可容纳价值。(其中i从0开始编号,考虑到i即从0-i的物品都考虑进去)。

递归方程:
(1)当w[i] > j的时候,说明放不下去,所以肯定不能放i号物品,所以:
m[i][j] = m[i-1][j]
(2)当w[i] <= j的时候,说明放的下去,那么问题就是放不放,如果放的话价值是m[i-1][j-w[i]] + v[i];如果不放下去,就是m[i][j] = m[i-1][j]。所以放不放显然取决于两个值的大小。

Charm Bracelet

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23
代码

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

const int N = 5e5+10;
int w[N];
int v[N];
int dp[N];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
    	memset(w,0,sizeof(w));
    	memset(v,0,sizeof(v));
    	memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            cin>>w[i]>>v[i];
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=w[i];j--)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            }
        }
        cout<<dp[m]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值