Kenken Race

题目描述
There are N squares arranged in a row, numbered 1,2,…,N from left to right. You are given a string S of length N consisting of . and #. If the i-th character of S is #, Square i contains a rock; if the i-th character of S is ., Square i is empty.
In the beginning, Snuke stands on Square A, and Fnuke stands on Square B.
You can repeat the following operation any number of times:
Choose Snuke or Fnuke, and make him jump one or two squares to the right. The destination must be one of the squares, and it must not contain a rock or the other person.
You want to repeat this operation so that Snuke will stand on Square C and Fnuke will stand on Square D.
Determine whether this is possible.

Constraints
4≤N≤200000
S is a string of length N consisting of . and #.
1≤A,B,C,D≤N
Square A, B, C and D do not contain a rock.
A, B, C and D are all different.
A<B
A<C
B<D

输入
Input is given from Standard Input in the following format:

N A B C D
S

输出
Print Yes if the objective is achievable, and No if it is not.

样例输入
7 1 3 6 7
.#…#…

样例输出
Yes

提示
The objective is achievable by, for example, moving the two persons as follows. (A and B represent Snuke and Fnuke, respectively.)

A#B.#…
A#.B#…
.#AB#…
.#A.#B.
.#.A#B.
.#.A#.B
.#…#AB

思路
当a与c或b与d之间存在两个连续的石头时,则不可到达
当上述条件成立时,
若c<d,则可到达
若c>d,则要判断b-1到d+1之间是否存在连续的三个空,使得Snuke能越过Fnuke到达c

代码实现

#include<bits/stdc++.h>
using namespace std;

const int N=200005;
const int mod=1000000007;
typedef long long ll;

int n,a,b,c,d;
char s[N];
bool fa,fb;

int main()
{
    scanf("%d%d%d%d%d",&n,&a,&b,&c,&d);
    scanf("%s",s+1);
    for(int i=a;i<c;i++)
    {
        if(s[i]=='#' && s[i+1]=='#')
        {
            fa=true;
            break;
        }
    }
    if(fa) printf("No\n");
    else
    {
        for(int i=b;i<d;i++)
        {
            if(s[i]=='#' && s[i+1]=='#')
            {
                fb=true;
                break;
            }
        }
        if(fb)  printf("No\n");
        else
        {
            if(c<d) printf("Yes\n");
            else
            {
                bool flag=false;
                for(int i=b;i<=d;i++)
                {
                    if(s[i-1]=='.' && s[i+1]=='.' && s[i]=='.' && i+1<=n && i-1>0)
                    {
                        flag=true;
                        break;
                    }
                }
                if(flag) printf("Yes\n");
                else printf("No\n");
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值