UVA - 10020 Minimal coverage (区间覆盖) (贪心) (day_6_I)

Minimal coverage

Given several segments of line (int the X axis) with coordinates [Li
, Ri
]. You are to choose the minimal
amount of them, such they would completely cover the segment [0, M].
Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri”
(|Li
|, |Ri
| ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair
‘0 0’.
Each test case will be separated by a single line.
Output
For each test case, in the first line of output your programm should print the minimal number of line
segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted
by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be
printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without
quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input
2
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0
Sample Output
0
1
0 1

题目简述:

给出很多区间,问最少需要几个区间能完全覆盖[0,m];

题目分析:

将区间依照区间左边界大小排序,初始当前已覆盖的右边界为0。在左边界小于当前已覆盖右边界的区间中找到右边界最大的区间,选取该区间,更新已覆盖右边界,知道已覆盖右边界大于等于m。

代码实现:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<stack>
#include<cstdlib>
#include<cmath>
#include<queue>
//#include <bits/stdc++.h>
using namespace std;

const int INF = 0x3f3f3f3f;
#define pf          printf
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define ms(i,j) memset(i,j,sizeof(i))

struct point
{
    double l,r;
    bool operator< (const point b)const
    {
        return l<b.l;
    }
} a[10005];
int main()
{
    int n,l,w,x,i,j,rt;
    while(~sfff(n,l,w))
    {
        int sum=0,k=0;
        for(int i=0; i<n; i++)
        {
            sff(x,rt);
            if(rt>((double)w)/2)
            {
                a[k].l=x-sqrt((double)rt*rt-((double)w)*((double)w)/4);
                a[k++].r=x+sqrt((double)rt*rt-((double)w)*((double)w)/4);
            }
        }
        sort(a,a+k);
        double r=0;
        for(i=0; i<k; i=j)
        {
            if(a[i].l>r)
                break;
            for(j=i+1; j<k&&a[j].l<=r; j++)
            {
                if(a[j].r>a[i].r)
                    i=j;
            }
            sum++;
            r=a[i].r;
            if(r>=l)
                break;
        }
        if(r>=l)
            pf("%d\n",sum);
        else
            pf("-1\n");
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值