Week 9 东东学打牌

题目描述

最近,东东沉迷于打牌。所以他找到 HRZ、ZJM 等人和他一起打牌。由于人数众多,东东稍微修改了亿下游戏规则:

所有扑克牌只按数字来算大小,忽略花色。
每张扑克牌的大小由一个值表示。A, 2, 3, 4, 5, 6, 7, 8, 9, 10, J, Q, K 分别指代 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13。
每个玩家抽得 5 张扑克牌,组成一手牌!(每种扑克牌的张数是无限的,你不用担心,东东家里有无数副扑克牌)
理所当然地,一手牌是有不同类型,并且有大小之分的。

举个栗子,现在东东的 “一手牌”(记为 α),瑞神的 “一手牌”(记为 β),要么 α > β,要么 α < β,要么 α = β。

那么这两个 “一手牌”,如何进行比较大小呢?首先对于不同类型的一手牌,其值的大小即下面的标号;对于同类型的一手牌,根据组成这手牌的 5 张牌不同,其值不同。下面依次列举了这手牌的形成规则:

  1. 大牌:这手牌不符合下面任一个形成规则。如果 α 和 β 都是大牌,那么定义它们的大小为组成这手牌的 5 张牌的大小总和。
  2. 对子:5 张牌中有 2 张牌的值相等。如果 α 和 β 都是对子,比较这个 “对子” 的大小,如果 α 和 β 的 “对子” 大小相等,那么比较剩下 3 张牌的总和。
  3. 两对:5 张牌中有两个不同的对子。如果 α 和 β
    都是两对,先比较双方较大的那个对子,如果相等,再比较双方较小的那个对子,如果还相等,只能比较 5 张牌中的最后那张牌组不成对子的牌。
  4. 三个:5 张牌中有 3 张牌的值相等。如果 α 和 β 都是 “三个”,比较这个 “三个” 的大小,如果 α 和 β 的 “三个”
    大小相等,那么比较剩下 2 张牌的总和。
  5. 三带二:5 张牌中有 3 张牌的值相等,另外 2 张牌值也相等。如果 α 和 β 都是 “三带二”,先比较它们的 “三个”
    的大小,如果相等,再比较 “对子” 的大小。
  6. 炸弹:5 张牌中有 4 张牌的值相等。如果 α 和 β 都是 “炸弹”,比较 “炸弹” 的大小,如果相等,比较剩下那张牌的大小。
  7. 顺子:5 张牌中形成 x, x+1, x+2, x+3, x+4。如果 α 和 β 都是 “顺子”,直接比较两个顺子的最大值。
  8. 龙顺:5 张牌分别为 10、J、Q、K、A。

作为一个称职的魔法师,东东得知了全场人手里 5 张牌的情况。他现在要输出一个排行榜。排行榜按照选手们的 “一手牌” 大小进行排序,如果两个选手的牌相等,那么人名字典序小的排在前面。

不料,此时一束宇宙射线扫过,为了躲避宇宙射线,东东慌乱中清空了他脑中的 Cache。请你告诉东东,全场人的排名

样例

Input

输入包含多组数据。每组输入开头一个整数 n (1 <= n <= 1e5),表明全场共多少人。
随后是 n 行,每行一个字符串 s1 和 s2 (1 <= |s1|,|s2| <= 10), s1 是对应人的名字,s2 是他手里的牌情况。

Output

对于每组测试数据,输出 n 行,即这次全场人的排名。

样例输入

3
DongDong AAA109
ZJM 678910
Hrz 678910

样例输出

Hrz
ZJM
DongDong

思路

需要将输入的牌的字符串转化成对应的大小,这里需要注意的是,10是两位,但是由于其余牌都没有以1开头的,所以只要字符串中出现1,则代表有10,于是遇到0时直接跳过即可

在判断牌型时,需要从最高的开始判断即从8-1判断,以确保序号大的牌型不会在序号小的牌型中重复计算

对于每个选手的牌的大小的排序,依次进行判断序号,关键字b、c、d,字典序

由于是多组数据,在每一次计算完成后要清空玩家数组

代码

#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
using namespace std;

int poker[5];
int num;
int n;

struct player
{
	string name;
	int index;
	int b,c,d;
	player()
	{
		index=b=c=d=0;
	}
	bool operator < (const player& x)const
	{
		if(index!=x.index)
			return index>x.index;
		if(b!=x.b)
			return b>x.b;
		if(c!=x.c)
			return c>x.c;
		if(d!=x.d)
			return d>x.d;
		return name<x.name;
	}
};

void change(string s)
{
	for(int i=0;i<s.size();i++)
	{
		if(s[i]=='A')
			poker[i-num]=1;
		else if(s[i]=='1')
		{
			poker[i-num]=10; 
			num++;
		}
		else if(s[i]>='2'&&s[i]<='9')
			poker[i-num]=s[i]-'0';
		else if(s[i]=='J')
			poker[i-num]=11;
		else if(s[i]=='Q')
			poker[i-num]=12;
		else if(s[i]=='K')
			poker[i-num]=13;
		else if(s[i]=='0') continue;	
	}
}

vector<player> players;

int main()
{
	while(cin>>n)
	{
		players.clear();
		for(int i=0;i<n;i++)
		{
			num=0;
			player p;
			string s;
			cin>>p.name;
			cin>>s;
			change(s);
			sort(poker,poker+5);
			
			//龙顺 
			if(poker[0]==1&&poker[1]==10&&poker[2]==11&&poker[3]==12&&poker[4]==13)
			{
				p.index=8;
				players.push_back(p);
				continue;
			}	
			
			//顺子
			if(poker[0]+1==poker[1]&&poker[1]+1==poker[2]&&poker[2]+1==poker[3]&&poker[3]+1==poker[4])
			{
				p.index=7;
				p.b=poker[4];
				players.push_back(p);
				continue;
			}
			
			//炸弹
			if(poker[0]==poker[3])
			{
				p.index=6;
				p.b=poker[1];
				p.c=poker[4];
				players.push_back(p);
				continue;
			}
			if(poker[1]==poker[4])
			{
				p.index=6;
				p.b=poker[1];
				p.c=poker[0];
				players.push_back(p);
				continue;
			}
			
			//三带二
			if(poker[0]==poker[2]&&poker[3]==poker[4])
			{
				p.index=5;
				p.b=poker[0];
				p.c=poker[3];
				players.push_back(p);
				continue;
			}
			if(poker[0]==poker[1]&&poker[2]==poker[4])
			{
				p.index=5;
				p.b=poker[2];
				p.c=poker[0];
				players.push_back(p);
				continue;
			}
			
			//三个
			if(poker[0]==poker[2])
			{
				p.index=4;
				p.b=poker[0];
				p.c=poker[3]+poker[4];
				players.push_back(p);
				continue;
			}
			if(poker[1]==poker[3])
			{
				p.index=4;
				p.b=poker[1];
				p.c=poker[0]+poker[4];
				players.push_back(p);
				continue;
			} 
			if(poker[2]==poker[4])
			{
				p.index=4;
				p.b=poker[2];
				p.c=poker[0]+poker[1];
				players.push_back(p);
				continue;
			}
			
			//两对
			if(poker[0]==poker[1])
			{
				if(poker[2]==poker[3])
				{
					p.index=3;
					p.b=poker[2];
					p.c=poker[0];
					p.d=poker[4];
					players.push_back(p);
					continue;
				}
				if(poker[3]==poker[4])
				{
					p.index=3;
					p.b=poker[3];
					p.c=poker[0];
					p.d=poker[2];
					players.push_back(p);
					continue;
				}
			}
			if(poker[1]==poker[2]&&poker[3]==poker[4])
			{
				p.index=3;
				p.b=poker[3];
				p.c=poker[1];
				p.d=poker[0];
				players.push_back(p);
				continue;
			}
			
			//对子
			if(poker[0]==poker[1])
			{
				p.index=2;
				p.b=poker[0];
				p.c=poker[2]+poker[3]+poker[4];
				players.push_back(p);
				continue;
			} 
			if(poker[1]==poker[2])
			{
				p.index=2;
				p.b=poker[1];
				p.c=poker[0]+poker[3]+poker[4];
				players.push_back(p);
				continue;
			}
			if(poker[2]==poker[3])
			{
				p.index=2;
				p.b=poker[2];
				p.c=poker[0]+poker[1]+poker[4];
				players.push_back(p);
				continue;
			}
			if(poker[3]==poker[4])
			{
				p.index=2;
				p.b=poker[3];
				p.c=poker[0]+poker[1]+poker[2];
				players.push_back(p);
				continue;
			}
			
			//其他情况
			p.index=1;
			p.b=poker[0]+poker[1]+poker[2]+poker[3]+poker[4];
			players.push_back(p);
			continue; 	
		} 
		
		sort(players.begin(),players.end());
		for(int i=0;i<players.size();i++)
		{
			cout<<players[i].name<<endl;
		}
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

yySakura

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值