1154 Vertex Coloring (25 分)

1154 Vertex Coloring (25 分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10
4
), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:
4-coloring
No
6-coloring
No
题目大意:合适的顶点颜色是同一条边的两个顶点的颜色不同,然后给你看个例子的点和边让你判断是不是合适的,是的话输出有多少种颜色k-coloring,不是的话输出No。
思路:将所有的边存起来,将所有的点存起来,读入的同时通过map(set、hash均可)记录读入颜色个数,然后对比每条边连接两点的颜色是否相同,有相同则输出No,否则输出记录的颜色个数。

#include<cstdio>
#include<vector>
#include<map>
using namespace std;
int n, m, t;
struct edge { int u, v; };
int main() {
	scanf("%d %d", &n, &m);
	vector<edge> G(m);
	for (int i = 0;i < m;++i)
		scanf("%d %d", &G[i].u, &G[i].v);
	scanf("%d", &t);
	for (int i = 0;i < t;++i) {
		bool flag = true;
		int colorNum = 0;
		vector<int> vertex;
		map<int, bool> mp;
		for (int j = 0;j < n;++j) {
			int color;
			scanf("%d", &color);
			if (mp.find(color) == mp.end()) mp[color] = colorNum++;
			vertex.push_back(color);
		}
		for (int k = 0;k < G.size();++k) {
			int u = G[k].u, v = G[k].v;
			if (vertex[u] == vertex[v]) {
				flag = false;
				break;
			}
		}
		if (flag == false) printf("No\n");
		else printf("%d-coloring\n", colorNum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值